4

To connect to the ethereum test network and sync the blockchain, I run:

parity --chain testnet

When I have to stop at some point, I do Ctrl+C and it says:

Finishing work, please wait... and quits

However when I check for processes running, I still see the process running:

/usr/local/bin/parity sync

I am doing kill -9 <pid> to kill the process. There has to be a better way. I couldn't find anything in the docs. What is a clean way to stop the node?

3

The answer is: Ctrl+C+Patience.

However when I check for processes running, I still see the process running.

I can reproduce this behaviour. The problem is the client processing a network DoS attack. It had been spammed for several weeks. You need to wait for a couple of minutes. Sometimes 10-15.

Yesterday (Oct-19, 2016) was a hard fork to mitigate that attack by increasing gas costs for several operations. After block 2,463,000 your synchronization process will go back to normal and Ctrl+C will work without the magic Patience component.

| improve this answer | |
  • I am having this issue on testnet. DoS attack on the main network wouldn't have any impact on the test network correct? – maheshmurthy Oct 19 '16 at 19:50
  • @5chdn how about for parity 1.9 on windows where its started not in a command window ? – wal Jan 29 '18 at 0:31
1

I just checked on my own parity node, and I'm getting a different result :

--- PARITY running

$ parity --testnet --jsonrpc-apis "eth,net,web3" --jsonrpc-cors '*' --jsonrpc-interface 0.0.0.0 --jsonrpc-port 8545 --jsonrpc-hosts="all"  --no-dapps

$ ps aux | grep parity
gregoir+ 23211 11.1  2.2 410128 168884 pts/0   Sl+  13:46   0:04 parity --testnet --jsonrpc-apis eth,net,web3 --jsonrpc-cors * --jsonrpc-interface 0.0.0.0 --jsonrpc-port 8545 --jsonrpc-hosts=all --no-dapps
gregoir+ 23225 13.5  0.6 184576 50820 pts/0    Sl+  13:47   0:05 /home/gregoire_jeanmart/.cargo/bin/parity sync
gregoir+ 23310  0.0  0.0  12944  1084 pts/2    S+   13:47   0:00 grep --color=auto parity

--- PARITY stopped (via Ctrl+C)

16-10-15 13:48:07 UTC Finishing work, please wait...

$ ps aux | grep parity
gregoir+ 23400  0.0  0.0  12944  1092 pts/2    S+   13:48   0:00 grep --color=auto parity

Well are you sure you don't have a daemon running ?

| improve this answer | |
  • I don't have a daemon running. I just tried: started the node and killed it within few seconds and it shut down cleanly. I then started again, let it find some peer nodes and start syncing and then killed and I see the process still running in the background. – maheshmurthy Oct 15 '16 at 14:06
  • You are only running parity --chain testnet (no more option after ?) .Otherwise, which version do you use (parity --version) ? – Greg Jeanmart Oct 15 '16 at 14:18
  • I have tried running with just --chain testnet and also the one you have above. Version is: Parity/v1.4.0-unstable-d6cad29-20161008/x86_64-macos/rustc1.12.0. I should have also mentioned, it is on mac os 10.11.4. – maheshmurthy Oct 15 '16 at 15:20
  • I tried to add more log by adding this option --logging debug but when I stopped Parity, I only got one more line 2016-10-15 17:05:34 UTC main DEBUG hyper::server closing server 0.0.0.0:8545. You can check if you have the result – Greg Jeanmart Oct 15 '16 at 17:09
  • Unfortunately I am seeing the exact same output after stopping, nothing else. – maheshmurthy Oct 15 '16 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.