1

Quick question...

... I'm trying to run a Parity public node but cannot connect to it from any computer other than the one it's running on.

Parity v1.8.6 on Windows 10 x64 - all updates

When I open 127.0.0.1:8180 from the computer it's running on I get the UI, no issues. When I try to connect from any other computer on my LAN to 192.168.1.4:8180 I get:

This site can’t be reached 192.168.1.4 refused to connect.

Parity is fully sync'd and I have no firewalls running on any of the computers. Not sure what I'm doing wrong here...

Thanks!

0

You are connecting to a port which is only listening on loop back interface, not exposed to the network. See https://github.com/paritytech/parity/wiki/Wallet-Remote-Access

  • I've seen that page before... running in Windows, I wasn't sure how to run an SSH server. Any suggestions on this? – RBizzle Jan 15 '18 at 14:55
  • How about this question and the comment? Does it solve your problem? ethereum.stackexchange.com/questions/28753/… – Franc Drobnič Jan 15 '18 at 15:42
  • Alright, so it looks like I have the SSH tunneling setup properly. I can connect to the Host now by tunneling 8180, 8545 and 8546 through the SSH tunnel. Now however, on the server I'm seeing messages like "Blocked connection from chrome extension://<bunch of letters> using invalid token." Anyone know how to resolve? – RBizzle Jan 15 '18 at 16:45
  • Maybe related to incorrect CORS settings, just a wild guess. – abb Jan 15 '18 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.