0

I'am trying to build this :

     PRIVATE_CONFIG=ignore nohup geth --datadir ./Node1/new- 
     node-1 --nodiscover --verbosity 5 --networkid 31337 -- 
     rpccorsdomain="*" --ws --wsorigins="*" --miner.gastarget 3300000 
     --miner.gaslimit 80000000000 --emitcheckpoints --raft --raftport 
     59001 --rpc --rpcaddr 0.0.0.0 --rpcport 29101 --rpcapi 
     admin,db,eth,debug,miner,net,shh,txpool,personal,web3,quorum,raft  
     --port 28101 --unlock 0 --password password.txt  
     2>>./node_logs/node1.log &

but this doesn't work. In node1.log Ihave this output flag provided but not defined: -emitcheckpoints and even I execute the command without -emitcheckpoint, I don't get flag provided but not defined: -raft I'am trying to launch a quorum node and I'am using raft as the consensus algorithm.

When I downloaded quorum using

   git clone https://github.com/jpmorganchase/quorum.git
   cd quorum
   make all

I get an error :

  build/env.sh go run build/ci.go install
  build/ci.go:61:2: use of internal package github.com/ethereum/go- 
  ethereum/internal/build not allowed
  Makefile:29: recipe for target 'all' failed
  make: *** [all] Error 1

when I go to build/ci.go:61:2 I have this instruction

  "github.com/ethereum/go-ethereum/internal/build"

Do anyone know how to solve the problems?

2

Firstly, the flag provided but not defined message means that you are running a standard Ethereum geth executable, not Quorum. You need to make sure the Quorum geth is the first one found in your path.

To build Quorum, follow the steps in the documentation. Ensure you have a valid version of golang (try 1.10.3 or 1.10.4) and that your GOPATH is set up correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.