Am starting off in blockchain development using the book Mastering Blockchain A deep dive into distributed ledgers...

Am using WSL.

$geth version
Version: 1.10.9-stable
Git Commit: eae3b1946a276ac099e0018fc792d9e8c3bfda6d
Architecture: amd64
Go Version: go1.17
Operating System: linux

Am trying to start geth but am getting the error that the --rpc flag is not defined

This the command am trying to run:

geth --datadir ~/etherprivate/ --networkid 111 --rpc --rpcapi 'web3,eth,net,debug,personal' --rpccorsdomain '*'

This is the output am getting:

flag provided but not defined: -rpc

I tried to use geth documentation as specified here https://geth.ethereum.org/docs/interface/command-line-options, but it seems like the rpc flags are not listed.

Any help on how it can be solved would be appreciated.

2 Answers 2


To anyone who may encounter such a problem in the future. All geth versions after 1.10.8-stable do not support rpc options they have been replaced with http

For example:

--rpc => --http

--rpcapi => --http.api

--rpccorsdomain => --http.corsdomain


It appears 1.10.9-stable version has a problem and is returning a -rpc error. I attempted to use http in place of rpc, since rpc is now deprecated, but the error also occurs for http (flag provided but not defined: -http)

GETH 1.10.8-stable version works fine when running the geth command with --rpc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.