Geth version

Version: 1.10.20-stable
Git Commit: 8f2416a89a3def6ec2c749d5afafbf2c9a18e3c8
Architecture: amd64
Go Version: go1.18.1
Operating System: linux


flag provided but not defined: -identification

My .sh file

geth --identification "miner1" --networkid 42 --mine --minerthreads 2 --datadir "~/RPI/miner1" --nodiscover --rpc --rpcport "8042" --port "30303" --rpccorsdomain "*" --nat "any" --rpcapi db,eth,web,web3,private,miner,admin,txpool,debug,personal,net --allow-insecure-unlock --unlock 0 --password ~/RPI/password.sec --ipcpath "~/.ethereum/geth.ipc"

Even if I remove identification the error changes to:

flag provided but not defined: -networkid

1 Answer 1


Answer found!

So each version of geth has some slightly different commands. For example rpc is now http.

I strongly recommend using geth help, as it will provide you with the list of all the commands that you may need for the version installed. Then you can check what you need and which command needs replacement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.