0

I am currently struggling to deploy my DApp to the POA testnet (https://sokol.poa.network).

I have a working DApp that I deployed to my local Ethereum testnet using truffle compile and truffle migrate.

Now I tried to run the DApp on the POA network instead. I changed my truffle.js file and it looks like like this:

module.exports = {
  networks: {
    development: {
      host: "https://sokol.poa.network",
      network_id: "*" // Match any network id
    }
  }
};

Just as suggested in the POA network docs I installed parity and I can open and interact with the parity interface normally, I even run parity with the insecure flag to enable RPC calls:

parity --geth  --warp --config dev-insecure --reseal-min-period 0 --jsonrpc-cors http://localhost  --chain spec.json --reserved-peers bootnodes.txt ui

I can interact with the POA network and use my wallets with parity normally.

Unfortunately it seems like truffle and parity do not communicate well with each other in my configuration when I try to deploy my contract.

When I try to run the command truffle migrate --reset (to deploy the smart contracts to the POA network I get the following error:

Could not connect to your Ethereum client. Please check that your Ethereum client:
 - is running
 - is accepting RPC connections (i.e., –rpc option is used in geth)
 - is accessible over the network
 - is properly configured in your Truffle configuration file (truffle.js)

What could I be missing to make this work? Is truffle even able to communicate with my parity node?

1

The command to deploy your contracts to the Parity network would be truffle migrate --reset --network development. 'Development' is the name of the network you specified in your truffle.js file.

It looks as though you're using truffle migrate --reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.