2

I use --geth to set Parity to geth mode. Because I want to use personal.unlockAccount and unlock an account permanently.(If don't set geth mode, it can't unlock permanently... which mentioned in this issue.)

But when I use --geth when I start my Parity. I can't visit my Parity UI... Before I set it, I can visit it with localhost:8180. But after I set it, I can't visit it with localhost:8180 or 127.0.0.1:8180 even 10.4.20.69:8180... How can I find back my webUI under geth mode? Thanks a lot.

This is my config:

[parity]
chain = "HyperAlbum-chain.json"
base_path = "node0"
[network]
port = 30300
[rpc]
port = 8540
apis = ["web3", "eth", "net", "personal", "parity", "parity_set", "traces", "rpc", "parity_accounts"]
interface = "10.4.20.69"
[ui]
port = 8180
[dapps]
port = 8080
[account]
password = ["node.pwds"]
[mining]
engine_signer = "0x00765Cc7584E3Ed11aE092b74d10AE2cE875aEAb"
reseal_on_txs = "none"
usd_per_tx = "0"

Thanks a lot. :)

1

Try

parity --geth --force-ui

This should enable the user interface for you even when running in geth compatibility mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.