0

I have two signing nodes on machine #1 and two new nodes on machine #2.

The nodes on #1 are running and I have them in admin under geth. But when I try and connect the nodes on #2 I get various errors. I think this is IP related. I did ifconfig on #1 and used the broadcast address.

I am using Ubuntu 16.04 and geth 1.8. The nodes on #1 seem to work. I use PoA and the network is private.

Has anyone any idea what could be the cause?

From #2 Connection Request -

geth --datadir node3/ --syncmode 'full' --port 30313 --rpc --rpcaddr 'localhost' --rpcport 8503 --rpcapi 'p ersonal,db,eth,net,web3,txpool,miner ' --bootnodes 'enode://601ade737b81f16abdd0ce9983b63eb12050c4ef89c46b8fdbf3e3e6c951cc02dffe36f87200033107cf 8b007355e780fba16b67d1d46603b1321f07 314ea46b@10.132.0.2:30310' --networkid 1515 --gasprice '1' -unlock 'afd3cfddc8f5ed78ea9bbbf6c13d3dc40be4541 7' --password node3/pwdnode3.txt --mine

Error on #2 -

ERROR[04-14|12:20:43] Bootstrap URL invalid
enode="enode://601ade737b81f16abdd0ce9983b63eb12050c4ef89c46b8fdbf3e3e6c951cc02dffe36f87200033107cf8b007355e780fba16b67d1d46603b1321f07\n314ea46b@10.132.0.2:30310" err="parse enode://601ade737b81f16abdd0ce9983b63eb12050c4ef89c46b8fdbf3e3e6c951cc02dffe36f87200033107cf8b007355e780fba16b67d1d46603b1321f07\n314ea46b@10.132.0.2:30310: net/url: invalid userinfo"

From #1

admin.nodeInfo

{ enode: "enode://64793e6e791115d315550d651cda00342b688ba36728b3d8070b04f4513ff65eb15ffb8f66387f1733340d8732e6ca956f0825cd3fc4e67686e04f63c5d0abc4@[::]:30311", id: "64793e6e791115d315550d651cda00342b688ba36728b3d8070b04f4513ff65eb15ffb8f66387f1733340d8732e6ca956f0825cd3fc4e67686e04f63c5d0abc4", ip: "::", listenAddr: "[::]:30311", name: "Geth/v1.8.2-stable-b8b9f7f4/linux-amd64/go1.9.4", ports: { discovery: 30311, listener: 30311 }, protocols: { eth: { config: { byzantiumBlock: 4, chainId: 1515, clique: {...}, eip150Block: 2, eip150Hash: "0x0000000000000000000000000000000000000000000000000000000000000000", eip155Block: 3, eip158Block: 3, homesteadBlock: 1 }, difficulty: 10593, genesis: "0x702d8ca9647d171a6596a775888f71c7c0f3ddb011fbffcb921be685b2ef33b7", head: "0x1a8f2a0bf37fbabff2c76977cbfa56c67da056025292fad6bbd5da07d2d0af28", network: 1515 } } }

This is how I connect on #1 and that works -

geth --datadir node1/ --syncmode 'full' --port 30311 --rpc --rpcaddr 'loca lhost' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --bootnod es 'enode://601ade737b81f16abdd0ce9983b63eb12050c4ef89c46b8fdbf3e3e6c951cc02dffe 36f87200033107cf8b007355e780fba16b67d1d46603b1321f07314ea46b@127.0.0.1:30310' -- networkid 1515 --gasprice '1' -unlock 'fcad53c780a4f6c66b3daca331fe72fc6559c367' --password node1/pwdnode1.txt --mine

2

You have a space in your nodeid -> ...f07 314...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.