1

I'm trying to configure geth on Redhat7 and facing an issue while connecting nodes from the two servers. There are three validator nodes on each machines and ports(30303, 30304, 30305) are allowed. But when I check peerCounts, it's showing 2 instead of 5.

I'm connecting these nodes using static-nodes.json file.

After checking port details, I found that geth uses ipv6 address. In order to check the actual issue. I want to make it to run with ipv4

enter image description here

Is there any way to force geth to use ipv4?

1

You question same as this Geth client: how to disable ipv6?. Try swith off using of ipv6 maybe it helps localize problem. Geth hasn't special args to control version of used ipv.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.