1

When I run truffle migrate --network kovan in the terminal the contract deployment doesn't run. Just:

Compiling your contracts...==================== >Eveything is up to date, there is nothing to compile

Here is my truffle-config.js code:

require('babel-polyfill');
require('dotenv').config();
const HDWalletProvider = require('truffle-hdwallet-provider-privkey');
const privateKeys = process.env.PRIVATE_KEYS || ""

module.exports = {
  networks: {
    development: {
      host: "127.0.0.1",
      port: 7545,
      network_id: "*" // Match any network id
    },
    kovan: {
      provider: function(){
        return new HDWalletProvider(
          privateKeys.split(','),
          'https://kovan.infura.io/v3/${process.env.INFURA_API_KEY}'
        )
      },
      gas: 5000000,
      gasPrice: 25000000000,
      network_id: 42
    }
  },
  contracts_directory: './src/contracts/',
  contracts_build_directory: './src/abis/',
  compilers: {
    solc: {
      optimizer: {
        enabled: true,
        runs: 200
      }
    }
  }
}

0

Eveything is up to date, there is nothing to compile

This means that your contracts have already been compiled and there is no need to recompile them. You can verify this by looking in your build/ directory to verify that your contracts are there.

If they are not there, then you have an issue with your deployment script. If this is the case, then you are not actually deploying the contracts in your script.

0

Deleting the build directory did it for me. After that it correctly re-deployed my contracts.

0

You have already compiled and deployed your smart contract. The message Eveything is up to date, there is nothing to compile occurs during migration when you try to deploy the same contract twice.

If you want to redeploy your contract to a new address you can use the --reset flag:

truffle migrate --network kovan --reset

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.