2

I have just installed Metamask version: 6.3.1

Now in Remix, the address of my account in metamask is not detected. The account box in remix remains always blank now (see picture below).

enter image description here

Note that I did not have this issue with an older version of metamask.

Question: How to resolve the above issue? so remix can detect metamask.

7

The reason it is not being read is because this version of Metamask enables privacy mode by default. What this does is require you to approve the application to view/use your wallets on Metamask.

For your specific issue, you have not yet approved Remix to use your accounts, therefore it cannot read your addresses, as you are seeing. To fix this, enable privacy mode by going the the Metamask settings and scrolling to the bottom.

Remix does not ask for permission to use the wallets like most Dapps do, therefore you must enable it in the settings, as opposed to approving the pop-up that you see on the tutorial.

  • 2
    thanks for the answer. That's a bad design... it'd be very hard to figure out the solution, without any help. – user153465 Apr 1 at 15:26
1

I'm not sure whether I missinterpreted Shane's answer. Going to the point to fix the problem he/she suggests that privacy should be enabled in metamask. In fact it must be disabled.

Metamask -> Settings -> Security & Privacy -> Privacy mode (disable it)

Just a further comment. Disabling the privacy mode you run into a les safe environment. Each time you make a transaction it will ask you to confirm it. Make sure that what you confirm is the actual transaction you asked for.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.