4

I'm having a very strange issue where mining using Geth on windows is very slow using in -dev mode. I have never had that issue before as i usually use OSX but the DAG load normally then 1 block is mined every 10+ minutes. When trying to transact with a contract it takes very long aswell. It's just basic dev mode never touched the genesis block or anything.

Anyone got any resources/clue/anything to help me fix this ?

I've reinstalled Geth , deleted all my wallet and tried with a new one, rebooted and all the like it just doesn't seem to work.

what i'm using:

geth -dev --rpc --rpcport 8545 --rpcaddr localhost  --rpccorsdomain "*" -mine
  • 2
    Make sure it's --dev not -dev – Tjaden Hess May 3 '16 at 1:16
  • 1
    And --mine not -mine... – Waqar Lim May 3 '16 at 8:39
  • thats not the issue, usually -- vs - doesn't change anything. but tried it anyway, still doesn't work. – user697 May 9 '16 at 13:16
1

Try geth --dev --rpc --rpcport 8545 --rpcaddr localhost --rpccorsdomain "*" --mine if it works there was a typo in your code.

Make sure you read Command line options

  • still doesn't work. Haven't figured it out yet if anyone can help.. it's not a syntax error. feeling a bit lost. – user697 May 9 '16 at 13:17
1

It's possible that geth is GPU mining on Mac OSX, but it's only CPU mining on Windows. In that case, the difficulty would be far too much for quick mining on Windows.

A simple way to resolve this is to manually create a testnet (with a custom genesis.json) and set the difficulty to some absurdly low number, therefore making even a slow PC mine quickly.

(If all you want is a testnet, you can testrpc to simulate an ultra-fast testnet.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.