0

I'm trying to mine test either on a private testnet using geth on windows 7, but do not appear to actually be mining anything. Geth seems to stall indefinitely after checking the DAG for epoch 0, while consuming 100% of my CPU. Ran it overnight in this state with no progress.

This is the command I'm using to start geth:

geth --identity "Anon" --rpc --rpcport "8080" --rpccorsdomain "*" --datadir "G:\EthTest" --port "30303" --nodiscover --rpcapi "db,eth,net,web3" --networkid 1999 console init genesis.json

The difficulty in my genesis block is "0x200"

I have tried allocating myself ether in the genesis block like this, and I still do not appear to have any test ether:

"alloc": {
"0xmy_account": { "balance": "10000000000000000000" }

Thanks!

  • console should be the final geth command, not init genesis.json. You should also mention the path for your genesis file. – galahad Jul 20 '16 at 15:58
  • Check this and this for problems related to DAG – galahad Jul 20 '16 at 16:01
  • genesis.json is in the same directory I'm launching geth from, but rearranging the args has worked, thanks! – Sawyer Jul 20 '16 at 16:15
0

Rearranging the args and launching the console with a separate command has fixed this. Mining success!

Here's the changed command:

geth --datadir "G:\EthTest" --identity "Anon" --rpc --rpcport "8080" --rpccorsdomain "*" --port "30303" --nodiscover --rpcapi "db,eth,net,web3" --networkid 1999 init genesis.json

geth --datadir "G:\EthTest" --identity "Anon" --rpc --rpcport "8080" -- rpccorsdomain "*" --port "30303" --nodiscover --rpcapi "db,eth,net,web3" --networkid 1999 console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.