0

Summary: tokens shown on Mist have a balance of 0, while I can see a positive balance on etherscan. DISCLAIMER: My geth is sync & I did add the token under the contracts tab.

I have some tokens in a ETH wallet I made using Mist. My Mist version is the latest (9.2), under ubuntu. Some Tokens I bought, some others I received by airdrop, like Xenon. They are all ERC-20. As everybody who has ether received some xenons, I will use this one as example. I can see them all on etherscan.io but it is stuck to 0 on Mist (and ethereumwallet).

No other question accross the web is helpful. When there are answers, they speak of some functions that I have no idea about (these functions don't work on the mist>toggle develop tool>mist UI>console).

Steps I have done:

  • Went to Contracts tab
  • clicked "add token" under "custom tokens"
  • entered Xenon address : 0xab95E915c123fdEd5BDfB6325e35ef5515F1EA69
  • entered Xenon under token name
  • entered XNN under token symbol
  • entered 18 under decimals

It shows 0.

My geth is sync in "light" mode. Back in the days, it was synced in normal mode, token balance was also 0 so the light mode is not the root of the problem. (not syncing in normal mode anymore, too slow).

I have tried the following:

  • added the token contract under "custom contracts", JSON interface was the one I found on etherscan: https://etherscan.io/address/0xab95e915c123fded5bdfb6325e35ef5515f1ea69 (under contract source, copied contract ABI). Did not help.
  • deleted all files under /home/[username]/.config/Mist (folder can be found under file>backup>application data) and restarted. Did not help.

Other possibly useful info:

  • I have a single account under the Wallets tab. It has >1 ether. There is no wallet contracts listed.
  • in the contracts tab, there is nothing else than the xenon custom contracts, the xenon token or the unicorns token (by default after fresh install of mist).
  • there are two errors showing up in the developper window that look irrelevant to my issue (unless the SourceSansPro font is used to show balance > 0?):

| |

SourceSansPro.otf Failed to load resource: net::ERR_FILE_NOT_FOUND
/sockjs/info?cb=h2d0g47fwv Failed to load resource: net::ERR_FILE_NOT_FOUND
  • In my best impersonation of Sherlock Holmes: When you have eliminated the impossible, whatever remains, however improbable, must be the truth. Are you looking at the same wallet address in both places? – Thomas Jay Rush Nov 5 '17 at 20:36
  • Thanks Sherlock! Yes it's sure, i copied and pasted the address from my mist to etherscan. Also i had to send the ether from the same address to get some other tokens. So I did do everything i was supposed to. Last resort is install/uninstall. I'll try from Windows – Wli Nov 5 '17 at 20:46
  • Watson here! Are you sure you're working in the same network? Can you exclude Mist is synced with ropsten instead of mainnet? – Davide C Nov 5 '17 at 22:45
  • I guess yes, otherwise i could not have bought some of the tokens as i used mist to buy them. Also other networks are greyed out. – Wli Nov 6 '17 at 6:13
0

I have set up the ethereum wallet on windows and imported my wallets. All my tokens appeared as planned.

Solution: run it on windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.