7

Trying to get testrpc (2.0.0) working on an ubuntu virtualbox, and getting this error when I run it:

mowliv@u4:~$ testrpc
module.js:341
    throw err;
    ^

Error: Cannot find module 'memdown'
    at Function.Module._resolveFilename (module.js:339:15)
    at Function.Module._load (module.js:290:25)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (/usr/lib/node_modules/ethereumjs-testrpc/node_modules/merkle-patricia-tree/baseTrie.js:3:17)
    at Module._compile (module.js:413:34)
    at Object.Module._extensions..js (module.js:422:10)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)

Have tried npm update -g and sudo npm install -g memdown but those didn't help. Maybe I'm being bitten by a major new (2.0.0) release?

  • try install memdown locally? – niksmac Apr 5 '16 at 17:08
  • @NikhilM I assume you mean without the -g. I tried both ways. – mowliv Apr 5 '16 at 17:33
  • Are you using ubuntu 14.04 or 15.10 ? I also use virtual box, everything works fine on 15.10 but when I tried on a 14.04 version I have the same error as you when launching testrpc. So if you tell me that you are using the older version, then it might be related to that. Good luck – SajZ Apr 7 '16 at 7:50
  • I was running on 14.04.04 LTS and was able to build. I have put in a pull request for documentation github.com/ethereum/browser-solidity/pull/97 not sure if you still get the problem? – Victory Jun 13 '16 at 22:31
  • 1
    Have you tried navigating to node_modules/memdown and npm installing there? – JohnAllen Sep 6 '17 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.