3

Hey guys I am new to the Ethereum and mostly cyrptocurrency mining world!

I have a problem when trying to set up Geth using CMD

It says that the command - "geth account new" is not working - Yes I am in CD drive.

I am using Windows 10 so would that be an issue?

Here is the result:

C:\>geth account new
'geth' is not recognized as an internal or external command,

operable program or batch file.

2

Either you don't have geth installed or you are not in the folder where geth is installed. Follow these steps to install geth in windows : Installation instruction for Windows.
Or follow simple instructions given at ethereum.org/cli

  • Download geth from here.
  • Unzip the .zip file downloaded.
  • Open terminal and navigate to path where you extracted the .zip file.
  • Run geth by `geth.exe'

.

1

Please follow the following steps after the installation then you will be able to run the "geth" command successfully.

Go to Control Panel

Select the System

Select Advance System Settings

In the open window of Advance System Setting click the Environment Variable button

In Environment Variable Window Select the Path Variable and press Edit Button

Then Just simply Copy the path of your Geth Installation directory like below and Save

"C:\Program Files (x86)\Geth"

Now go to command Prompt you will be able to find the "geth" Command

0

In my case, It was directory problem. GO to : C:\Program Files\Geth Open command prompt there using Shift + right click on folder and choose "open command window here"

Now type "geth".

0

I ran into the same issue, just make sure that when in Power Shell you navigate into the geth folder then try to run the command "geth"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.