2

Mist Version: 0.10.0 OS & Version: windows/64 Node version: geth 8.11.1

Screen shot : https://i.sstatic.net/SqGsO.jpg

I've created a private network all fine but when I attache and miner.start(1); the kh/s show in Mist but I keep waiting and no ether got mine not a single one!!!

https://codeshare.io/GqxZ3Z this is the code of the first command line where I start geth

https://codeshare.io/2pgZYX this is the second terminal where I start mining command

Genisis file:

{ "coinbase" : "0x0000000000000000000000000000000000000001", 
  "difficulty" : "0x20000", 
 "extraData" : "", 
 "gasLimit" : "0x8000000", 
 "nonce" : "0x0000000000000042", 
 "mixhash" : "0x0000000000000000000000000000000000000000000000000000000000000000", 
 "parentHash" : "0x0000000000000000000000000000000000000000000000000000000000000000", 
 "timestamp" : "0x00", "alloc": {}, "config": { "chainId": 15, "homesteadBlock": 0, "eip155Block": 0, "eip158Block": 0 } }

thanks guys

13
  • Can you edit your question to add your genesis file? Are you sure you are mining in a private network and not mainnet? Can you try launching geth with more logs enabled with --verbosity 4?
    – Ismael
    May 12, 2018 at 3:05
  • Genisis got added, yes I'm pretty sure, don't know how to do that
    – user39465
    May 12, 2018 at 15:37
  • Your difficulty is too high I'd start with 0x200 or lower. If you modify your genesis you have to start again your blockchain to delete all previous data. To discard an ipc issue type your command mine.start(1) in the console of same instance.
    – Ismael
    May 12, 2018 at 15:52
  • I will start over with 0x200 difficulty so i have to delete all files data and start again, right?
    – user39465
    May 12, 2018 at 16:00
  • I've deleted the 2 files inside chaindata which are "geth" & "keystore" then make difficulty 0x200 and start a new private chain using init, and start geth, open mist and attach all fine but when start.miner i get this error of coinbase: imgur.com/a/0iUskES
    – user39465
    May 12, 2018 at 16:51

1 Answer 1

0

I think this is because you have an error about the IPC from your geth running command. (bottom left in red)

5
  • What will cause the error? The remixx eth address is correct what will be the problem?
    – user39465
    May 10, 2018 at 0:33
  • Can you add your geth command line to your post please?
    – oktapodia
    May 10, 2018 at 0:40
  • Any thoughts yet about the error?
    – user39465
    May 10, 2018 at 4:49
  • Not 100% sure about but the --mine option is not needed to run a private miner? github.com/ethereum/go-ethereum#running-a-private-miner
    – oktapodia
    May 10, 2018 at 11:12
  • Honestly I don't know
    – user39465
    May 10, 2018 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.