I updated my node and nvm version. Then I ran truffle develop command on my project folder, this command doesn't return anything.. why?

it just stays... local blockchain dosen't start.


Truffle v5.1.25 (core: 5.1.25)
Solidity v0.5.16 (solc-js)
Node v14.2.0
Web3.js v1.2.1

I removed the truffle on my machine and than I installed again but I get same result.

Also truffle console command result is here:

> Something went wrong while attempting to connect to the network. Check your network configuration.

Could not connect to your Ethereum client with the following parameters:
    - host       >
    - port       > 7545
    - network_id > 5777
Please check that your Ethereum client:
    - is running
    - is accepting RPC connections (i.e., "--rpc" option is used in geth)
    - is accessible over the network
    - is properly configured in your Truffle configuration file (truffle-config.js)

Truffle v5.1.25 (core: 5.1.25)
Node v14.2.0


I downgrade the truffle from 5.1.x to 5.0.x and truffle develop is ran.

  • Are you on windows? I'll suggest downgrading node. The last version of node that worked for me without problems was node 10. As an alternative you can try WSL.
    – Ismael
    Commented May 13, 2020 at 18:24
  • No, on macOS. Actually it was working properly. I updated the node then truffle develop mode did not up.
    – sollover
    Commented May 13, 2020 at 19:47
  • Anyway I'll suggest to try downgrading node to version 12, node 14 is just too new perhaps some dependency isn't working correctly.
    – Ismael
    Commented May 13, 2020 at 20:15
  • the error continues... also I edited and add truffle console command result. what is the problem?
    – sollover
    Commented May 14, 2020 at 12:57
  • There are some remaining issues with node 12 github.com/trufflesuite/truffle/issues/2070. Using node 10 on windows and node 12 on linux work for basic development.
    – Ismael
    Commented May 14, 2020 at 13:10

3 Answers 3


Node 12 works with truffle version 5.0.x and 5.1.x

I had to downgrade node that I installed through 'brew install node' which installed node version 14.12.0.

steps to downgrade node using brew...

  1. brew install node@12
  2. brew unlink node
  3. brew link --force --overwrite node@12

back in your truffle project folder

$ truffle version
Truffle v5.1.47 (core: 5.1.47)
Solidity v0.5.16 (solc-js)
Node v12.18.4
Web3.js v1.2.1

truffle develop should now work...


had a similar issue. all I had to do was uncomment the development key under networks in the truffle.config.js and the contracts migrated to dev blockchain just fine.

screenshot - truffle.config.js


I just closed vscode and restarted the laptop. And the truffle develop command started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.