0

I am getting a python version error while installing web3js from npm

gyp ERR! stack Error: Python executable "/anaconda3/bin/python" is v3.6.4, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.

Is there any way of installing web@1.0.0 and better version while working on python3 only

2

Your problem is caused by node-gyp. You can try npm config set python python2.7 or if you have node-gyp installed node-gyp --python=python2.7 or create a new conda env with python v2.7 and try executing the command within that env.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.