Each time i try to unlock my account w/ password i get the error:

Fatal: Failed to unlock account 0x1288AB0bf7FE0Ad09d7f28bd4Ab2C06332c625a2 (no key for given address or file)

my geth command is: geth --rinkeby --rpc --rpcapi db,eth,net,web3,personal --unlock="0x1288AB0bf7FE0Ad09d7f28bd4Ab2C06332c625a2"

When testing this same information on myetherwallet.com and the rinkeby testnet w/ my created password I am able to access my account without a problem.


 module.exports = {
  networks: {
    development: {
      host: 'localhost',
      gas: 6000000,
      port: 8545,
      network_id: '4000'
    rinkeby: {
      host: "localhost", // Connect to geth on the specified
      port: 8545,
      from: "0x1288AB0bf7FE0Ad09d7f28bd4Ab2B06332e625a2",
      network_id: 4,
      gas: 4612388

Is there any step i'm missing here for deploying my contract to the testnet?

  • I still can't figure out the issue locally.. However I was able to deploy by generating bytecode in remix and deploying it via metamask. Leaving issue open incase anyone can still help me get to the bottom of this.
    – i am E
    Jul 19, 2018 at 21:53
  • Did you use the --pasword command line option?
    – Ismael
    Jul 23, 2018 at 3:18
  • Sign the transaction and don’t unlock account, see truffle hd wallet provider
    – Majd TL
    Mar 27, 2021 at 20:49

1 Answer 1


I think your rinkeby fields are incorrect. I would consider using infura and truffle as described here to access ropsten/rinkeby and so on. Here the link https://truffleframework.com/tutorials/using-infura-custom-provider

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.