1

January is almost done, and so my first test of Ethereum. The first 2 weeks I was doing pool mining, and I must say it worked really easy. About a week ago I decided to do the Solo mining thing, and I think I might have gained a couple of gray hairs since then. My problem, I can't get geth node to sync past a point.

My scrapyard rig:

  • Intel(R) Core(TM)2 Quad CPU Q6600
  • 2 x 2GB DDR 800 MHz RAM
  • SSD HDD
  • 2 x Nvidia 1070
  • Ubuntu 16

My setup

  • geth as per the official instruction with apt-get
  • ethminer as per the official instruction with source compilation

I start geth in a screen window with

 geth --cache=256 --rpc --rpccorsdomain localhost console 2>&1 | tee /tmp/eth.log

I have gotten as far as ~80% once, but it then just starts from 0 again.

Once it hit a fork..

a couple of time it got very slow around 20~30 %, I stop it. Start new

a couple of time it just jumps back to way under 50%, I stop it. Start new

I have now tried about 5 times to start from 0, by deleting the folder $HOME/.ethereum and more recently only $HOME/.ethereum/geth/chaindata

I have since started a backup folder of the chaindata, as it's really big.

Attempt 6 is currently at 25 %.. (The javascript)

Is there something I am missing?

  • Without answering your actual question, have you checked to see how profitable solo mining is going to be with your hardware? (I'm thinking along the lines of "do you really need to be running a full node...".) – Richard Horrocks Jan 27 '18 at 19:54
  • I couldn't find a way to run ethminer solo without the geth node. Pool mining is not really that profitable.... the node just hit 50% – Willem P. Botha Jan 27 '18 at 19:58
  • Yep, I understand that you need to be fully synced to mine, it's just that I'm suspecting solo mining will be even less profitable, I'm afraid: etherscan.io/ether-mining-calculator – Richard Horrocks Jan 27 '18 at 19:59
  • using my hashrate of 55, cost off 0.22 and about 500W, it's about 50% less profitable that pool mining. But the test is to give solo mining a fair chance. If I can just get this node to finish it's sync [57%] – Willem P. Botha Jan 27 '18 at 20:07
  • and right after I get 78% ... The node freezes up.. I restart it and am back to 1 %.... running real slow :( – Willem P. Botha Jan 27 '18 at 21:45
0

So after spending another day with all sorts of tweaking and optimization I have come to a conclusion.

This rig can not run a node and mine at the same time.

It hardly has enough power to get a node running right. Besides the fact that there are a couple of bad peers out there that tend to lagg the node every now and then, geth nodes are just everything but easy.

For mining this setup is however the bare minimum, but I do recommend more RAM.

My Next step:

  1. Try and get a node on a Root Hosted server.
  2. Attempt to Solo mine with the new online Node.
  • I started my node on my Root server about 30 min ago with 50 peers, and it just zipped past 70% – Willem P. Botha Jan 28 '18 at 19:33
  • at ~80% I started having trouble, and had to reduce the peers to 12 for it to stay stable. – Willem P. Botha Jan 29 '18 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.