2

I've been trying to sync for several days with the latest stable build of geth on Ubuntu 16.04

My latest attempt I ran the command as follows, after clearing the db:

geth --rpc --sync-mode=fast --cache=1024

What I've noticed happening is that it will sync to a point, and then arbitrarily restart. For example, the other day it got to a block receipt with a number in the neighbourhood of 3.5 million. At some point I noticed it had all of a sudden went back down to block receipts numbering in the tens of thousands. When I scrolled up through the output there were no error messages or indication of why it would've done this.

This has happened on a couple fresh syncs. Not always in the 3 millions but sometimes in the 1 millions or 2 millions.

It occurred to me that I may be just misunderstanding the output, as the processed states goes up the whole time even when the block receipt numbers suddenly start at 0 again. Any tips would be great.

  • This is because it downloads the headers first, and then pulls all the blocks after. It looks like you are starting over, but it really does not. – Afr Jun 9 '17 at 10:12
1

I think you can only --fast download a blockchain the first time. That is, from the start.

Thereafter, if you start again, (I am not sure about it) it will go from start all over again.

When you start geth, there will be three block counts. One for --fast, other for --light and other for full block.

What are your intentions? Just to sync to make transactions or to mine blocks, too?

0

There's three things I've tried.

  1. Stop mining if you are
  2. wired connection until the sync
  3. change cache value from 1024 to 2048
  • Definitely not mining at the moment, also already wired. I will give adjusting cache size a shot. Thank you! – Zeerus45 Jun 1 '17 at 17:08
0

For those syncing a node right now, as of Aug 29, 2017 there are ~22,000,000 state entries in a fast sync.

Here's the final log entry

INFO [08-29|17:33:08] Imported new state entries count=3 elapsed=479.731µs processed=22003274 pending=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.