The setup of Ethereum Mist worked like a charm (MacOS). Then, I tried to connect to a test Network but the program crashed and continues to do so.

How can I fix this issue?

Node type: geth

Network: main

Platform: darwin (Architecure x64)

...eum/geth/ethash count=3
INFO [10-14|17:34:19] Disk storage enabled for ethash DAGs     dir=/Users/stefanschares/.ethash                      count=2
INFO [10-14|17:34:19] Initialising Ethereum protocol           versions="[63 62]" network=1
INFO [10-14|17:34:19] Loaded most recent local header          number=4362351 hash=188b4f…0c8c34 td=1174172911787544706344
INFO [10-14|17:34:19] Loaded most recent local full block      number=0       hash=d4e567…cb8fa3 td=17179869184
INFO [10-14|17:34:19] Loaded most recent local fast block      number=4362114 hash=d11d53…f16574 td=1173445059230676622547
INFO [10-14|17:34:19] Upgrading chain index                    type=bloombits percentage=0
INFO [10-14|17:34:19] Loaded local transaction journal         transactions=0 dropped=0
INFO [10-14|17:34:19] Regenerated local transaction journal    transactions=0 accounts=0
INFO [10-14|17:34:19] Starting P2P networking 
Fatal: Error starting protocol stack: listen udp :30303: bind: 
address already in use

It is impossible to be sure with the information you have provided, but please check that Mist isn't trying to use a port that is already in use. This is the most common issue that causes the Mist client to crash - namely port 30303.

You can find other common issues and fixes here:



It clearly states

Fatal: Error starting protocol stack: listen udp :30303: bind: address already in use

It is possible you have another instance running. Try a fresh reboot to ensure any instances are closed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.