4

Im running a geth (1.3.5) node on a Windows 8 mining rig. Doing that for some month now, i couldnt solve the following problem/behavior:

- After starting the node i get connected to 10-15 peers
- the connection seems stable for like +- one day
- after that day the peer number starts dropping slowly
- 2-3 days after starting the node the peer count is zero
- i restart the node and the same behavior starts from the beginning

i tried
- to have my time syncronised --> should be correct (tried different time servers but samesame)
- disabling my firewall/antivirus... everything --> did not change anything
- to add nodes manually --> admin.addNode

nothing helped..
what else could cause this or what am i not thinking of?

  • 1
    latency might be a problem. i had the same problem and i end up disable mining. – niksmac Mar 22 '16 at 12:23
  • is there a way to check this and be sure thats the problem? – Pepethereum Mar 22 '16 at 15:07
  • latency can be checked if you configured the node to show up in ethstats.net. I am unaware of any other methods. – niksmac Mar 22 '16 at 15:11
  • I added the bug tag because I am totally reproducing this problem with my geth miners. Maybe we should report that upstream. – Waqar Lim Mar 23 '16 at 10:26
  • Please open an issue on our GitHub tracker: github.com/ethereum/go-ethereum/issues, but also please check if the develop branch works for you, because the issue may have already been solved upstream, just not shipped yet. – Péter Szilágyi Mar 23 '16 at 12:32
2

We've seen occasional reports of such behavior, alas given that it needs 2-3 days to crop up we haven't been able to reproduce it ourselves (I personally have both main net and test net nodes running 24/7 for weeks and didn't see sync issues as of yet).

Since we can't reproduce it ourselves, could you help us out in doing a repro? To do such a thing we'd need detailed logs, the accumulation of which would probably be way too unwieldy. We've added an RPC endpoint to 1.4 (develop branch) that can turn on logging for an already running node. If you'd like to help, please run a develop build for a few days and when the issue crops up, attach to the node with a console, enable logging (debug.verbosity(6)), let it run for a few minutes (10?) and upload the logs to a GitHub gist and open an issue on our tracker so we may investigate.

  • I think I can do that since this randomly happens to my mining rigs. – Waqar Lim Mar 30 '16 at 8:58
  • im on it too ... having this issue on two different mining rigs – Pepethereum Apr 7 '16 at 11:11
  • is it possible to save the logs into a file directly? or do i just copy&paste from the command window(for that i have to adjust the window buffer size but i guess i wont be able to get the whole logs for 10min+) – Pepethereum Apr 8 '16 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.