9

We have been running a private ethereum network for a couple of months.

Today we tried to add a new node to the network. When the node was synchronizing, (after 3-4 hours) it stopped with the following message :

5a0e number=847268 hash=0000...0000 allowance=847268 WARN [03-23|15:11:45] Synchronization failed dropping peer 5a0e err="retrieved ancestor invalid"

We tried it again by starting from scratch (deleting all retrieved chain) and the same problem appeared again at the same number=847268.

I will appreciate your help on resolving this issue.

3

I had the same problem but solved it in the following way.

  1. Go to your chaindata directory like "/home/user/.ethereum/testnet/geth/chaindata"

  2. Delete some of the recent ldb files and .log file. ( I've deleted 10 recent files.)

  • Got Fatal: Error starting protocol stack: missing block number for head header hash after doing this. – denis.peplin Nov 13 '17 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.