0

This question already has an answer here:

I ran geth --fast --cache=1024 which was the recommended for faster syncing. It goes up to reach the maximum block once, then goes to the beginning and imports chain segments again. This second process is extremely slow and as it goes up it only gets slower.

I really don't want to delete the blockchain again and re-run the process as it has taken 4 days to get here number=1259407. I was under the assumption that with fast option this will be done in less than a day. Is there something I'm missing?

Also my real question is, is it possible to connect to a remote blockchain instead of downloading it? (like electrum for BTC), or a feasible way to get an Ether wallet.

Specs:

Ram: 16GB
CPU: Intel Core i7-3720QM @ 2.60 GHz
Network: Ethernet @ 36Mb

NOTE (for duplicate query) I have followed all options and instructions on the other questions relating to slow sync but none actually help.

marked as duplicate by Ismael, Thomas Jay Rush, Tjaden Hess, jeff, niksmac Jul 9 '17 at 7:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It would be good to post your query about connecting to a remote blockchain as a separate question because it is not related to the slow syncing issue. – Ajoy Bhatia Jul 6 '17 at 23:45
  • What kind of disk are you using? With an SSD disk and a good internet connection it should be done in a couple of hours. – Ismael Jul 7 '17 at 3:47
  • external hard drive with USB.3 connection. and Network connection is very good – Arijoon Jul 7 '17 at 7:09
  • Who owns the LAN you're connected to? If it's not yours, do you know if they have any traffic-shaping/Quality of Service policies on specific ports? – Richard Horrocks Jul 7 '17 at 9:41
  • I own the LAN, I meant to type Ethernet connection instead of LAN, Is there anywhere with the description of what the second sync process is actually doing? Since it has already gone up to the num of blocks once, but then restarted. – Arijoon Jul 7 '17 at 11:04
1

When using the --fast option (it's actually default, so no need to specify it) you will usually download the complete blockchain in 4hours if you have an SSD. Using a HDD will take significantly longer, but this is worked on (won't help you right here and now).

It's very important to note, that --fast only works if you have no blockchain data. So do not start with --fast, leave it on for 2h then restart with --fast. The second time will use the "slow" method and that might explain some of the delay. If for some reason you have to quit before it's done, it's better to delete the blockchain and restart.

It's possible to connect to a remove blockchain. Two ways basically.

(1) Use a site which have their own node that you interact with (like myetherwallet.com).

(2) use the experimental light client (geth --light), but this is very early in development an I can't recommend it right now for real world applications.

  • I did remove the entire blockchain, and to be safe, I actually used a different --datadir when I ran with --fast. The process wasn't stopped until today. Can you tell me what the second sync process does as opposed to first (it runs from 0 to latest block number twice) – Arijoon Jul 7 '17 at 11:58
  • I can't in detail explain the difference between fast and normal sync. It has to do with verification of the blocks (in normal mode you actually execute each transaction). – xgabrielx Jul 7 '17 at 12:32
  • I only ran --fast, by that logic the second sync should not take place right? So it should download the blockchain and finish? But this started from the beginning when it reached the top once. – Arijoon Jul 7 '17 at 13:12
  • Correct, only one download is normal. – xgabrielx Jul 7 '17 at 13:58
  • Then something must have gone wrong with my initial run since that only took 1-2 days and there were no interruptions. – Arijoon Jul 7 '17 at 14:51
0

If geth doesn't work, you can try downloading parity wallet as an alternative. It's a bit faster. If you don't want to try that, bump up your cache to cache=2048

Not the answer you're looking for? Browse other questions tagged or ask your own question.