I have seen other posts in reddit where users experienced slow sync times. I am using windows 10 and version 3.7 (I saw on gitter that other users on windows 10 had trouble with version 3.8 crashing).

My download speed is 4.19 MBS. I have adjusted clock to (time.nist.gov). I am still not able to sync and it has been hours, probably at least 10 and I am only halfway through.

Any suggestions? Also I notice that when I close and reopen, only about a third of the time am I offered the option to "skip search for peers". Lastly, I tried to open an account when not in sync. I was able to enter and confirm password, however no new account showed.

  1. Is it a problem with Windows ?
  2. Is it a problem with network speed?
  • 2
    Long sync times are normal (unfortunately) - when I updated it about a week ago it took significantly more than 10 hours ;) – Joël Jan 25 '16 at 1:43
  • I think there is some compatibility issue. Sometimes it gets hung up on blocks and i have to restart. Most of the time it tries to sync without option to go into application - skip peer search. The second time i went into application i did see account created but shortly after lost peers. – Skier Jan 25 '16 at 7:10
  • 3
    I am truly surprised how rough this is. I thought it would be much further along. I too went with my ether wallet paper wallet as few options available. – Skier Jan 25 '16 at 7:13
  • 1
    I've had the exact same experience - this is in active development so you can't expect a super smooth UX I'm afraid. – Joël Jan 25 '16 at 7:13
  • 1
    10 hours you gotta be joking, i have been updating since the last 2 months!!! – PirateApp Jul 20 '17 at 11:09

I am using Windows 10, Mist Wallet 0.7.2 which includes geth v1.3.6, a non-SSD hard drive and ethernet connection to 16Mbs modem.

I had incredibly slow syncing of the blockchain, even with 25 peers and was actually having to to quit and restart Mist just to download another few blocks. I had installed the Mist Wallet for Win64 from here, which also includes a CLI called geth. (nb. apparently x32 editions don't contain geth?)

I followed numerous different recommendations, however none worked until I deleted the blockchain data using geth and kicked the whole process off again.

Rather than using the Mist sync process, I removed the chaindata and then ran geth --fast:

  • Opened the cmd prompt

  • Navigated to the directory containing geth.exe and opened it

  • Copied the file path from the bar Explorer

  • Typed cd path/to/geth (replace path/to/geth with what you copied) and hit enter.

  • Typed geth removedb and hit enter.

  • Once the blockchain was removed, I ran geth --fast

This above is also described here.

The download has now got to block 500,000 in 30 minutes which had previously taken 3 days!

If you are on a Mac, you would do this...

  • Right click on the ethereum-wallet.app and select 'show package contents'

  • Open 'contents', then 'frameworks', then 'node', then 'geth' and voila.

  • Then you should right click on geth and select 'show info'.

  • Copy the location marked 'Where:'.

  • Open Terminal and type 'cd `

  • Then type: ./geth --fast

Other recommended changes to Windows I had performed were:

Whether any of these contributed to it being much faster after the geth removedb I'm not sure, but each of those may well help you.

The complete download of 1,500,000 blocks finished after about 10 hours, so the blocks definitely appear to take longer to download the greater the block number, due to the increased number of transactions contained in each block.

  • This is phenomenal. All the info. One place. Clearly stated. Can you add how you got geth to run in the CLI? Did you have it installed already separately or did you navigate to the geth folder. Could you add that to your answer, please? Thank you. – tayvano May 10 '16 at 19:15
  • 1
    Updated, thanks! – JonoMac May 11 '16 at 11:29
  • I have also just read this site which has stated that geth.exe priority should be reduced down to Low or Below Normal, and affinity to just one CPU. Not sure if that is of any help also? forum.daohub.org/t/access-to-and-selling-dao-tokens/5556/7 – JonoMac Jul 1 '16 at 13:49
  • 3
    Would be great to update the Mac section for current Ethereum wallet. Geth no longer appears to be part of it. I find c++ eth instead, with no --fast option. – mowliv Oct 30 '16 at 13:39
  • 1
    I now use parity and warp sync with mist.... Far quicker than geth! – JonoMac Oct 24 '17 at 17:17

Use --fast and don't forget --cache with Geth

Everyone mentions --fast but you probably also need --cache=1024 (and --jitvm may also help). Without it, you are running with the default which is --cache=16.

--fast is important to help sync past computationally intensive blocks.

If you are starting from the beginning, use: geth --fast --cache=1024

If you already have some of the blockchain, use: geth --cache=1024. If it's taking too long, you may be in the process of syncing the computationally intensive blocks and deleting the blockchain with geth removedb and restarting the fast sync will be faster.

Depending on your RAM, you can also try with higher values, like --cache=2048.

Source

If you are using the geth client, there are some things you can do to speed up the time it takes to download the Ethereum blockchain. If you choose to use the --fast flag to perform an Ethereum fast sync, you will not retain past transaction data.

Note

You cannot use this flag after performing all or part of a normal sync operation, meaning you should not have any portion of the Ethereum blockchain downloaded before using this command. See this Ethereum Stack.Exchange answer for more information.

Below are some flags to use when you want to sync your client more quickly.

--fast

This flag enables fast syncing through state downloads rather than downloading the full block data. This will also reduce the size of your blockchain dramatically. NOTE: --fast can only be run if you are syncing your blockchain from scratch and only the first time you download the blockchain for security reasons. See this Reddit post for more information.

--cache=1024

Megabytes of memory allocated to internal caching (min 16MB / database forced). Default is 16MB, so increasing this to 256, 512, 1024 (1GB), or 2048 (2GB) depending on how much RAM your computer has should make a difference.

--jitvm

This flag enables the JIT VM.

  • This actually made all the difference. Thank you! – Slavic Jun 22 '17 at 12:35
  • I agree with this answer, but I would add that at least in my case a big difference was made by running geth with the flags described above AND the --rpc flag. Why I don't know, the syncing is still running after about 3.5 hours and currently it seems to be stalled. But I left it stalled a couple of hours ago and eventually it continued. – manu3d Aug 24 '17 at 20:08

Geth is a CLI Ethereum client that helps the Mist Wallet application connect to the Ethereum network (you also have the option to use the C++ client, but Mist defaults to using Geth currently). If loading Mist (or Geth) is taking a long time to download/load the blockchain, try this:

  1. Download geth
  2. Run geth with the --fast option. Example: geth --fast
  3. After geth has finished syncing the blockchain in the console/terminal window, open your Mist Wallet application if you are using it. It should load with the latest blockchain data.

The "Ethereum Fast Syncing" option is very new and there are still some bugs pre-homestead. However, if you're able to find a node that is running the latest Ethereum client version, it should be able to perform a fast sync with you, saving download time and hard drive space.

More about fast sync in Ethereum:

  • Fyi, you don't need to close geth before you launch mist. Mist accepts any running node or starts it's own. – Afri Feb 6 '16 at 13:38
  • 1
    Ah, good catch. Editing answer. – Hudson Jameson Feb 6 '16 at 17:45

Running geth.exe instead of downloading the blockchain with mist is working for me. Its in the resources/node/geth folder of mist.

  • OP is asking to find out whats wrong with his set up, not what works for all of us. – niksmac May 13 '16 at 16:15
  • interesting; other answers suggest downloading geth separatedly, any word on what's better? – knocte May 14 '16 at 11:22
  • since mist only launches the geth instance, it should be the same turnout. – Afri May 19 '16 at 11:04

Thank you so much i had the same Problem with Sync. I have changed the Clock Settings to time.nist.gov and now i have made the Commands from you.

Opened the cmd prompt

Navigated to the directory containing geth.exe and opened it

Copied the file path from the bar Explorer

Typed cd path/to/geth (replace path/to/geth with what you copied) and hit enter.

Typed geth removedb and hit enter.

Once the blockchain was removed, I ran geth --fast

And now it works great only 30 minutes for Sync :) Thanks

I am running Windows 10 on a slow Core i5 1.7GHz w/ 8GB.

If you have part of the blockchain downloaded already, you can't use --fast.

  • The major thing that sped things up for me was stopping Superfetch in the task manager. It is under one of the Service Hosts. It was fighting geth for hard disk resources.

  • I also stopped other heavy processes (Dropbox, OneDrive, Skype, etc.).

It seemed that my computer was processing blocks so slowly that my P2P connections on the network would drop me, so syncing would stop while geth looked for new connections.

Also, eth<> is correct. uping your cache helps the speed a bit. I used --cache=4096. It speed things up by about 50%.

Anyways, I'm now downloading at a pace that will update me to the current block (1,571,255) in around 10 hours.

Mist also have geth.exe , eth.exe in it's packages. in CLI geth alone also slow compared than before DAOHUB.

I estimates that there are so many new geth nodes , compared existing nodes. So, slow synchronization.

And If you're a little bit more fast and stable synchronization then just execute geth.exe theirs no overhead on MIST ux.

  • @Hudson Jameson I'm not recommend to use --fast option. It's some problem with integrity with my homestead release experience. but, If there's no update on geth then --fast is also alternative choice. – cpplover - Slw Essencial May 13 '16 at 9:36

Updating the clients' situation to November, 2017:

In Ethereum Wallet or Mist 0.9.x you can sync using the light client, which is still under an experimental label.

That will get you up to speed in a matter of minutes, instead of hours.

You can also start Geth via command line:

geth --syncmode light

For me the disabling the "Superfetch" service in windows task manager ( open services under the services tab) was enough , it seemed like windows 7/8/8.1 and 10 use to much ram space for cache data ( although the OS is smart enough to remove all the unnecessary cache when needed [like when you open big programms] ) , but those wallet software aren't that evolved much yet to solve this problem by itself.

The Superfetch service in windows is existing for userlogin programms and datas in the RAM where the user has already used those once or uses frequently.

Nodes before disabling -> 1-9 now -> 1-28

Blockchains downloaded within 2 hours

protected by Afri May 15 '17 at 9:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.