I installed Geth, and successfully synced the blockchain. However, regardless of whether I use Ethminer, Ethminer with Stratum Proxy, or qtMiner; I always get the same error. It doesn't really throw an error; the mining application just crashes. For ethminer, the command I used is:

ethminer -U -F http://eth-eu.dwarfpool.com:80/0xc780f6a9de1cca4e3e5bb25e9dfe0ee52d6d87a6 (source)

The output I get is:

Forked from github.com/ethereum/cpp-ethereum
CUDA kernel ported from Tim Hughes' OpenCL kernel
With contributions from RoBiK, tpruvot and sp_

Please consider a donation to:
ETH: 0xeb9310b185455f863f526dab3d245809f6854b4d

Using grid size 8192, block size 128

Found suitable CUDA device [GeForce GTX 980 Ti] with 6442450944 bytes of GPU memory
miner  15:47:47|main  Getting work package...
miner  15:47:47|main  Grabbing DAG for #129656ac…

When I use ethminer with Stratum Proxy, I get this line of output while ethminer is running:

2017-06-22 16:48:19,914 INFO proxy # Hashrate for 2130706433 is 0.0 MHs

Here's the troubleshooting I've tried so far:

  • Using different miners (qtminer, ethminer, etc.)
  • Using different mining pools (dwarfpool, ethermine, etc.)
  • Clearing the blockchain and resyncing more times than I can count

I am attempting to mine on my Windows 10 machine with a NVIDIA GeForce GTX 980 Ti card. At this point, I've spent several days reading/trying everything I can. I suspect there's something dumb that I overlooked. Any thoughts? Thanks!


Two observations:

  1. If I switch ethminer to mine Expanse (change eth-eu.dwarfpool.com:80 to exp-eu.dwarfpool.com:81), then everything works perfectly.
  2. I tried claymore miner, and it works. However, it was much slower than mining EXP with ethminer; so I would prefer to figure out how to get ethminer mining ETH properly.
  • Someone makes the same complaint here: reddit.com/r/EtherMining/comments/6h5ywm/… - many Solutions proposed, a few different ones apparently worked. It came down to one of: The OS thought the Miner was a Virus and blocked it, something wrong with the compilation of the Library .dll (and copying one from elsewhere worked), to change your Mining Software. -- Figure out if one of those Solutions is applicable to you and if needed please refine your question, then write your own answer to your question. Thanks.
    – Rob
    Jun 25 '17 at 2:29
  • So here's a fun fact: if I change the command to use exp-eu.dwarfpool.com:81 instead of eth-eu.dwarfpool.com:80 to mine Expanse, ethminer works perfectly. So why can I grab DAG for EXP but not for ETH? Jun 26 '17 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.