4

When I run ethminer -G it starts the miner as expected. It takes around 60 seconds to allocate the DAG, and then it starts pumping out hashes on the GPU (at a dismal 1MH/s but that's besides the point.)

 cl  09:49:13|cl-0      DAG 93 %
 cl  09:49:13|cl-0      Switch time 52536 ms / 49530777 us
  m  09:49:13|main      Speed   0.00 Mh/s    gpu/0  0.00  [A0+0:R0+0:F0] Time: 00:00
  m  09:49:14|main      Speed   1.04 Mh/s    gpu/0  1.04  [A0+0:R0+0:F0] Time: 00:00
  m  09:49:14|main      Speed   1.04 Mh/s    gpu/0  1.04  [A0+0:R0+0:F0] Time: 00:00

However, when I attempt to connect to a pool, for example ethminer -F http://eth1.nanopool.org:8888/0xddb296fbb8882e35e500747bf684f63687437431 -G then it sputters with

 X  09:52:39|cl-0      Creating DAG buffer failed: clCreateBuffer -61 
 X  09:52:39|cl-0      OpenCL Error: clEnqueueWriteBuffer -38

If it wasn't working with just the -G I would understand it and have some debugging to do. But I fail to see why having the payload come from a pool instead of locally would cause it to fail so.

I notice the buffer sizes are different - on the non-pool version, I get cl 09:48:27|cl-0 Creating DAG buffer, size 1073739904 but on the pool version I get cl 09:52:39|cl-0 Creating DAG buffer, size 2298476672 so this is likely the cause of the problem - but I still don't see why it exists.

If I try a different pool will that change things? What options do I have?

  • Yea I think your best bet is to first manually delete the existing DAG file from your system and try again. If that does not work I would just try another pool. – Nicholas Porter Sep 13 '18 at 23:24
  • Also updating your EthMiner and drivers for your GPU is always a good thing to do. – Nicholas Porter Sep 13 '18 at 23:25
0

first check your mining pool info update, then check updates on your miner software

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.