0

Trying to do the Status ICO, and when entering in the ether address, I get this warning. A friend has tried this with another wallet and said he's getting an error/exception and his transaction did not go through. Any ideas what's going on? Even if I set the "Send after BLockNumber" condition the exception message does not go away. note that the BlockNumber has already passed.

enter image description here

Edit: I tried sending, and got this

Warning! Error encountered during contract execution [Bad instruction]

1

The transaction caused contract execution that would lead to some kind of 'invalid' condition.

In the case of the status ICO, there are two likely causes:

  1. The sale had already reached its cap, so when you sent funds, it caused an error on this line:

    assert(totalCollected() <= failSafeLimit);
    

This is most likely, and Parity probably detected this even before you tried to send.

  1. You tried to include too much gas, which cause an error on this line:

    require(tx.gasprice <= maxGasPrice);
    

For a bit of extra context, assert and require are similar. They will cause the transaction to fail, your ETH send will be refunded, but all of the gas you pay for will be used up.

  • If it's reached it's cap, then how are transactions still going throw every second? So here's a recent transaction (someone else) that's currently pending. Notice it doesn't say "Contract" next to the "To:", did I send it incorrectly? etherscan.io/tx/… Here was mine which got rejected: etherscan.io/tx/… – LampShade Jun 20 '17 at 20:43
  • I have no idea why people are still sending, but that transaction will ultimately have the same fate as yours. Ie. it was sent way too late, and will eventually be rejected in the same way. – maurelian Jun 20 '17 at 20:55
  • Yeah I see. I'm looking at recent transactions and once they get about a minute old they get flagged as such. This one doesn't seem to be yet though. This one from 6 minutes ago went through... I don't really understand why it worked. etherscan.io/tx/… – LampShade Jun 20 '17 at 20:56
  • Looks like that one went through in the end. Could you upvote and accept my initial answer, I think it was sufficient for the original question. – maurelian Jun 21 '17 at 12:21
  • Yes, your answer is correct. That tx referenced wasn't mine. It was someone else's that worked around the time I sent mine. – LampShade Jun 21 '17 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.