3

Does anyone here have experience with the etherparty/explorer blockchain explorer? I am having trouble connecting. I keep getting the error message

"Allow Access to Geth and Refresh the Page"

when I access localhost:8000.

I was running geth and had the same error messages, but now I am running parity. Here is how I invoke parity:

parity --chain dev  --dapps-apis-all --jsonrpc-cors "http://localhost:8000" --jsonrpc-apis "web3, eth" --jsonrpc-hosts="all" --networkid="<private-number>" --force-ui --ui-no-validation

Here is how etherparty/explorer says to invoke geth:

geth --rpc --rpccorsdomain "http://localhost:8000"

The RPC port is available at localhost:8545.

EDIT: I have since tested with geth, using the main net. I get the same error. So I am trying other things. Maybe it's how I'm installing (or failing to install) web3?

  • Does it work if you remove the jsonrpc-apis flag? Just a thought. – Waqar Lim Mar 17 '17 at 7:45
  • @5chdn: no it doesn't. Out of curiosity, why did you think it might? The doc specifically says to use that. I'm not criticizing, I just want to know what your thought was. – stone.212 Mar 17 '17 at 23:28
  • Was just thinking maybe some api calls are not accepted. – Waqar Lim Mar 17 '17 at 23:39
2

Not a complete answer, but might help...

Poking around at their code, the error is output when this part is run:

    if(!web3.isConnected()) {
        $('#connectwarning').modal({keyboard:false,backdrop:'static'}) 
        $('#connectwarning').modal('show') 
    }

Which implies there's a failure in the following code:

var eth_node_url = 'http://localhost:8545'; // TODO: remote URL
web3.setProvider(new web3.providers.HttpProvider(eth_node_url));
  • Ah, yes. So I could hack it by giving that a false positive (since I know web3 is connected.) Thank you. I will let you know how it goes tomorrow. – stone.212 Mar 17 '17 at 9:02
  • Sounds like a plan. I've updated the answer with a link to the part of their code. – Richard Horrocks Mar 17 '17 at 9:08
  • Or have a look at @5chdn's idea in the comment on the question :-) – Richard Horrocks Mar 17 '17 at 9:10
  • Actually I think I may have failed to install web3. I thought I did it (ran "bower install" in the parity directory) but maybe not.... – stone.212 Mar 17 '17 at 23:52
  • That wasn't it. I see ""GET /bower_components/web3/dist/web3.min.js" "Mozilla...." And I have re-installed geth, so it's not parity. I'm puzzled but I guess I'll just start digging through the code. BTW when I "fixed" those lines nothing displayed at all. That's what made me think maybe web3 wasn't available. – stone.212 Mar 18 '17 at 0:31
0

I did all of these things. But the problem was that the site has to be viewed in a graphical browser. Since the explorer runs server-side, I was SSHed in and viewing with w3m. Once I looked at the code pointed out by @Richard Horrocks, it became clear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.