I recently registered to Infura and trying to connect to the Ethereum Mainnet using the command below ({MY_PROJECT_ID} is swapped for my actual project id)

curl -H 'Content-Type: application/json' \
>       -X POST \
>       -d '{"id":1, "jsonrpc": "2.0", "method": "eth_getBalance","params":["0xfe05a3e72235c9f92fd9f2282f41a8154d6d342b", "latest"]]}' \
>       ropsten.infura.io/v3/{MY_PROJECT_ID}

It times out and outputs the following error here: https://gist.github.com/Genysys/6bbb8eb6415cd3c6c6b591dee741db91

I have tried other networks but run into the same issue.

I would be appreciative of any pointers on this

1 Answer 1


There was an issue with the network i was connecting from. Had to Hotspot off my phone and it works now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.