0

Every time I try to send ETH to my locally deployed contract I get errors like this:

enter image description here

-While the error message says "out of gas" I know that can't be true since all my accounts have like 100ETH in them.

-The address to which I'm trying to send the ETH is that of a crowdsale contract I successfully deployed to localhost 8545 using truffle migrate

-I've tested this contract multiple times in truffle console by calling its functions - everything works fine, which is how I know its deployment was successful

-I'm not using geth or anything special - just localhost 8545

What's the problem here?

0

Apparently its a MetaMask quirk - you just need to reset it once in a while:

-go to Settings (tapping on the Icon in the top-right corner of the MetaMask window will bring out a menu, and if you scroll down that menu you'll eventually find Settings)

-Once in Settings, scroll down to, locate, and then tap on the Reset Account button

Voila.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.