0

While using truffle.cmd console I tried to use the compile option, or even init. These options are not available, so I cannot compile using console.

truffle(development)> .help

.break Sometimes you get stuck, this gets you out

.clear Break, and also clear the local context

.editor Enter editor mode

.exit Exit the repl

.help Print this help message

.load Load JS from a file into the REPL session

.save Save all evaluated commands in this REPL session to a file

truffle(development)>

I tried using truffle in PowerShell but still no resolution: could not see compile, or init options, when using .help

  • sounds like you should reinstalling truffle, maybe try using truffle in regular cmd – GrandFleet Oct 30 '18 at 16:33
0

The follwoing worked for compilation: (the --all aoption for truffle.cmd)

truffle.cmd compile --all

Compiling .\contracts\Adoption.sol...

Compiling .\contracts\Migrations.sol...

Writing artifacts to .\build\contracts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.