I installed Geth to work with Web3 and used npm install -g ethereumjs-testrpc but when i run testrpc the following error shows

testrpc is not recognized as an internal or external command,operable program or batch file.

Is there any additional package or something that I should use to make this work?

2 Answers 2


From the npm docs the testrpc package has been deprecated and moved to ganache-cli. My suggestion is to use that instead. But if you want to use test rpc then use the command

geth --rpc to set it going. Of course it would be better to check if you have the latest geth version as well in case it does not work but so far I have been using this in my testing and it worked flawlessly.


This package has been deprecated https://www.npmjs.com/package/ethereumjs-testrpc

ethereumjs-testrpc has been renamed to ganache-cli, would be better to use new one.

If you face the issue again, make sure that Environment Variables contain path to C:\Users\<user>\AppData\Roaming\npm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.