1

I am new to ethereum. I installed mist on Mac(10.13.5), but did not "brew install ethereum". When try run ">geth attach" in Terminal, it does not show "miner" module. Below is what the screen shows "Welcome to the Geth JavaScript console!

instance: Geth/v1.8.8-stable-2688dab4/darwin-amd64/go1.10.1 modules: admin:1.0 debug:1.0 eth:1.0 net:1.0 personal:1.0 rpc:1.0 txpool:1.0 web3:1.0". Could anyone please let me know what's wrong? Thanks.

0

There is no such thing like miner module in geth.

When you start up your ethereum node with geth it is not mining by default. To start it in mining mode, you use the --mine command line option. The --minerthreads parameter can be used to set the number parallel mining threads (defaulting to the total number of processor cores).

geth --mine --minerthreads=4
  • thanks for your answer. it does mine using the above command line. What i am asking is, in the geth console, when i run "miner.start()", it shows " ReferenceError: 'miner' is not defined at <anonymous>:1:1" . do you know what's wrong? – Chen Jun 5 '18 at 12:49
0

I am not sure how you are starting geth initially, but if you include miner in the rpcapi like below it should work fine.

$geth --datadir=./chaindata/ --ipcpath $HOME/.ethereum/geth.ipc --rpc --rpcapi db,eth,net,web3,personal,miner

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.