2

not sure if anyone has seen this before: I'm trying to mine a private chain. For whatever reason, after I was able to mine two blocks, I tried to mine the chain again and I get the following...(below)...any ideas to troubleshoot? TIA. JD

> miner.start(1)
INFO [07-03|19:18:00] Updated mining threads                   threads=1
INFO [07-03|19:18:00] Transaction pool price threshold updated price=18000000000
INFO [07-03|19:18:00] Starting mining operation 
null
> INFO [07-03|19:18:00] Commit new mining work                   number=3 txs=0 uncles=0 elapsed=104.511µs
  • It is ok to me, null is the result of miner.start(1), I think it is a javascript thing. But the blocks should generated correctly. Check eth.blockNumber. – Ismael Jul 4 '17 at 1:44
  • that doesn't work – user12506 Jul 5 '17 at 13:34
  • Try starting a second node miner, which would mine it, as a workaround. – 1sn0s Feb 9 '18 at 14:00
0

What is your geth command used to start your private network?
I also encountered this problem before and fixed it by adding the flag --dev, which uses a preconfigured private network.

reference: https://github.com/ethereum/go-ethereum/wiki/Command-Line-Options

  • where do you add --dev ? the commands i'm using are: geth --datadir ~/.jdchain99 init ~/.jdchain99 and geth --datadir ~/.jdchain99 --port "44444" --networkid 99 console – user12506 Jul 4 '17 at 16:10
  • that doesn't work – user12506 Jul 5 '17 at 13:34
  • what does your genesis file look like? Maybe it is because you set the mining difficulty too high so you'll have to wait longer. In my case, it started mining after I change the difficulty from 2000000 to 20. I wrote a tutorial about this: medium.com/@tina26919742/… Hope you find it useful:) – Tina Lee Jul 5 '17 at 23:20
0

Try to increase the verbosity of the log to max level i.e 6 by giving this is command line while starting geth --verbosity 6. This will give us some clue. Generally the mining takes time to start because it is required to generate DAG

0

miner.start(1) is return null in some time. But that not mean that mining is not done. Mining process is done based on you system capacity. Also you can check your hash rate using eth.hashrate command in javascript console. Hope it helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.