I have had problems with Ethereum Wallet for a couple weeks. It started after not synching for a while due to travelling. When I got back online, it needed to sync a lot and it got really slow. After a few days I kept getting errors that it couldn't connect without anything more in the logs. I read somewhere that I had to remove the chaindata and let it sync from scratch. Have done that, but after syncing to near completion, I still couldn't see the content of my wallet (confirmed that it holds coins on etherchain.org) and it slowed down. When I restarted the wallet I got the following error:

Unable to connect. Please start geth with the following options:

geth --rpc --rpccorsdomain "file://"

Optional add: --unlock .

* I have no idea how this would be done. CLI? from where?

I'm using Windows 10/Ethereum Wallet 0.8.10 and have had no significant problems before (besides the ones that disappear upon a restart).

This is all very frustrating. I have a significant amount of money in my wallet and even though I plan to keep it that way the idea that my money is inaccessible is not fun. How can I fix this? I'm completely stumped as to what I can do more. Are there any other offline wallets I could move to and how (since I'm pretty much locked out of the Ethereum Wallet software)? Thanks for your suggestions and time in advance.

  • Do you realy need a full node? Downlaod Etherwallet and open it locally github.com/kvhnuke/etherwallet/releases/tag/v3.8.9 With the private key you can see/send your ether via etherwallet too. Jun 12, 2017 at 7:39
  • I don't need a full node. Like to contribute, but if it comes at the price of not being able to do anything with it, I choose not to. Thanks for the response will report back if I got it to work.
    – forkerino
    Jun 12, 2017 at 7:43
  • Ok, I got it to work. Interesting to see how it all fits together. This is code I can read, so will dive into this etherwallet to see how it works.
    – forkerino
    Jun 12, 2017 at 8:10

2 Answers 2


Use Etherwallet:

Download Etherwallet and open index.html locally with your browser:


With the private key you can see/send your ether via local etherwallet instance.


I have been trying for a week now with the same issues. Uninstalling ,reinstalling, deleting blockchain over and over for the testnet.Main network would never download. Used geth --fast and it told me my time was out by 57.something seconds. I had tried gist.gov and Microsoft time over and over. When i went in and changed the clock manually by around 57 secs, the blocks started pouring in. I believe yours and everyone else's problem is the timing sync not the wallet software or config. Try geth --fast and see what your response is in regard to the time warning. I would bet its the same as my issue.

A week people, but i persevered,tried every possible combination of answers here but it was the clock all along. Good luck everyone. Hope this helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.