3

When I tried to run my Ethereum Mist wallet yesterday I ran into two problems:

1.) When starting up version 0.8.7 I got a popup that said:

*"Couldn't connect to node? See the logs for more:*

*Node type: geth* 

*Network: main* 

*Platform: win32 (Architecure x64)*

*...flag provided but not defined: -support-dao-fork"*


And an error on the main screen saying:


*"Ethereum node connection error :'(*

*Checking network..."*

This problem wasn't there two days ago.

2.) So I tried installing 0.8.8 but I'm not sure what to do.

Is it enough to simply copy ethereum wallet.exe from the 'win-unpacked' folder and delete the rest of the files or do these files serve a new/update function as well? Last couple of releases were simply .exe files that I installed, after which I simply deleted the prior ethereum-wallet.exe file.

Don't want two versions running next to eachother and a computer with Ethereum files all over the place. With the basic .exe files that were offered before you didn't have to choose a location for installation or anything. So there's nothing in the 'program files' folder, only in the 'local' and 'roaming' folders under 'app data'.

Thanks in advance.

1

Make sure all instances of Ethereum Wallet.exe are closed in your process explorer.

If your computer is 64 bits, try running Mist-win64 instead of Wallet.

https://github.com/ethereum/mist/releases

I don't know if I'm the only one to whom it's happening, but using geth.exe from the Wallet win64 build crashes due to not enough memory, however using geth.exe from the mist64 client works perfectly. You might be experiencing the same issue.

-2

don't put it at the end of your file, like after console attach and then --support-dao-fork do this before the last words.

  • This answer was auto-flagged and it is hard to understand. Perhaps put in the example command in your answer? And quote it with ` so that it will be formatted well. – eth Jan 5 '17 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.