3

I am trying to run one of the methods of my smart contract using Remix and I am getting the following:

enter image description here

Why is not possible anymore to see if this is failing on a require, with the right description of the error? It used to be that way.

It is very hard to know what is going on with my smart contract with these kind of errors. Is there a way to enable this back?

    require(lockUntil > block.timestamp, "lockUntil must be greater than the current block height");

I want to see the second part of the require if that's the problem, not just this.

1 Answer 1

1

I have observed this. It got really bad to correct errors and debug now. Before, everything was better. That update they made was really bad.

They made this update and a solution (mandatory) is to send the transaction to the network for debug.

I even contacted them via email. I'm talking to see if they can fix this.

3
  • Awesome, hope you can get a reply soon and share some details. Thank you. Mar 30, 2023 at 22:54
  • 1
    After a few emails I've sent them, this issue seems to be fixed.
    – Ether Man
    Apr 13, 2023 at 2:32
  • 1
    Just checked and that is correct. Thank you so much for taking the time. Apr 13, 2023 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.