1

I am new at ethereum mining and I am trying to solo mine. I already installed geth and now I am trying to mine. When I go to ethereum software folder and type ethminer -G, it gives me the following error:

miner 20:17:35.189|main Getting work package... X 20:17:36.390|main Failed to submit hashrate. X 20:17:36.393|main Dynamic exception type: class jsonrpc::JsonRpcException std::exception::what: Exception -32003 : Client connector error: libcurl error: 7 -> Could not connect to http://127.0.0.1:8545

JSON-RPC problem. Probably couldn't connect. Retrying in 1...

What can be the problem?

migrated from stackoverflow.com Apr 6 '17 at 18:10

This question came from our site for professional and enthusiast programmers.

  • How does this involve C++? – NathanOliver Apr 6 '17 at 16:24
  • Ethereum is somehow using it. Even folder is called cpp-ethereum. So I guess it may be the cause of problem. – GeorgeDopeG Apr 6 '17 at 16:25
  • That is not how the tags work. If you have a problem with actual C++ code then you use the C++ tag. – NathanOliver Apr 6 '17 at 16:26
  • how did you started miner? In ethereum you generally define the services that you want to enable for miner while starting the miner in cmd line args – radbrawler Apr 6 '17 at 16:32
  • @radbrawler I didn't pass any arguments, as the tutorial said, i just typed ethminer -G. any suggestions ? – GeorgeDopeG Apr 6 '17 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy