Hot answers tagged

32

Run as a systemd service Create a file geth.service: [Unit] Description=Ethereum go client [Service] Type=simple ExecStart=geth 2>%h/.ethereum/geth.log [Install] WantedBy=default.target Enable service: systemctl --user enable geth.service systemctl --user start geth.service Source. Alternatively you could use screen: sudo apt-get update && ...


14

Just using this command is enough for me: nohup geth --rpc & To check if service is running: ps ax | grep geth To explore last log messages: tail -f nohup.out To stop the service I use: pkill geth


3

ethcore parity Issue 1560 reported that daemon was not logging and it was fixed in this commit --log-file FILENAME Specify a filename into which logging should be directed. Use parity daemon --log-file /path/to/parity.log For different logging customizations check How to make parity write logs?


2

Here is an update to 5chdn's answer that uses systemd. This shows how to run a headless geth on your Ubuntu server. Of course, you must install the command line tools first, see https://www.ethereum.org/cli. You should also run MyEtherWallet on your normal desktop computer to create an account + private key so you can receive funds. Step 1: put on your ...


2

When you close your Putty session it delivers a hang-up signal (SIGHUP) to the Geth daemon, which causes it to close. The Putty session is Geth's parent process, regardless of using the --daemon option, so its children will die with it. Note that I think some care has to be taken when Geth closes in this way. I don't think Geth has proper signal handlers ...


1

Run as a systemd service Create a file geth.service: [Unit] Description=Ethereum go client [Service] Type=simple ExecStart=geth 2>%h/.ethereum/geth.log [Install] WantedBy=default.target Enable service: systemctl --user enable geth.service systemctl --user start geth.service Source. Alternatively you could use screen: sudo apt-get update && ...


1

It sounds like the socket is not connected to your geth instance. I saw here that geth.ipc could cause problems, you can try: rm -f /home/my_local_username/.ethereum/testnet/geth.ipc I don't see the bug myself but this socket stays when hard killing geth and could be in a bad state for you. You should also check the logs on starting geth to see if any ...


Only top voted, non community-wiki answers of a minimum length are eligible