Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [vscode]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
14 views

slither error: "No such file or directory: 'out/build-info'"

I am attempting to run this slither command: slither . --solc-remaps @openzeppelin/contracts/=lib/openzeppelin-contracts/contracts/ And I'm running into the following error: 'forge clean' running (wd:...
Steiner254's user avatar
0 votes
1 answer
30 views

Not able to Change version of Solidity Compiler from 0.7.3 to 0.8.25 VS Code

I am getting following error while Compiling my Solidity Program. Compiling using solidity from node_modules, solidity version: 0.7.3+commit.9bfce1f6.Emscripten.clang c:/Users/ADMIN/aave-flash-loan-...
Udayarajan gauthaman's user avatar
0 votes
1 answer
40 views

Insufficient Allowance ERC20 when adding liquidity to Uniswap V2 Pool

I am trying to create a contract with a Uniswap V2 Pair for my TestMe Token on Sepolia Testnet. Smart Contract: // SPDX-License-Identifier: MIT pragma solidity 0.8.24; import "lib/openzeppelin-...
SolidityNewbie's user avatar
1 vote
1 answer
20 views

Getting method hardhat_impersonateAccount not supported when impersonating a WETH whale account on Arbitrum

Attempting to impersonate a WETH whale account on arbitrum and getting: ProviderError: method hardhat_impersonateAccount not supported The code is being run from a script using the following command ...
Ian Forsyth 's user avatar
1 vote
0 answers
28 views

Truffle deployment Failed " hit an invalid opcode while deploying."

This is a token maker code, so its failing to deploy with the following reason: > *** Deployment Failed *** "TokenMaker" hit an invalid opcode while deploying. Try: * Verifying that ...
emkiddo's user avatar
  • 21
0 votes
1 answer
16 views

Compiler run failed

So a bit of a N00b problem, Error (6275): Source "/root/solidity-course/src/SimpleStorage.sol" not found: File not found. Searched the following locations: "/root/solidity-course"....
neo_maredi's user avatar
0 votes
0 answers
65 views

Getting error "Could not fetch chain ID. Is your RPC URL correct?" in metamask while trying to add Anvil running on wsl

I was trying to add the Anvil to add on metamask, which was running in WSL. In my VScode the Anvil is running: What is causing the problem here ? How to fix the problem ?
Asir Shahriar Roudra's user avatar
0 votes
1 answer
73 views

Prettier not detecting solidity

Prettier formatting is working for typescript but not for solidity. I have tried uninstalling and installing Prettier and Solidity(by JuanBlanco) extension again but still no luck. Below are my ...
Haris Nabeel's user avatar
1 vote
1 answer
37 views

Remix plugin for VS Code reads 404

On the official Remix website Remix - Ethereum IDE & community the link to Ethereum Remix VS Code Extension reads 404. How could one find the official extension?
arturasmckwcz's user avatar
0 votes
0 answers
66 views

Foundry importing files results in "File not found. Searched the following locations: "" " but does compile

I'm using foundry forge init to setup a new project. The Counter files which comes built-in when creating a project also have imports: e.g. Counter.t.sol has "import ../src/Counter.sol"; ...
Delvir0's user avatar
  • 115
2 votes
1 answer
217 views

Solidity debugger in VS Code

Is there a good Solidity debugger out there for Foundry that gives you the same UX in VS code as when debugging a node.js app? Like local/state variables inspection, breakpoints, etc?
dNyrM's user avatar
  • 918
0 votes
0 answers
81 views

Segmentation fault when running forge init

I got the "Segmentation fault" when I tried to run the command "forge init".chatgpt answer is "A Segmentation fault is a specific kind of error caused by accessing memory that ...
kumar's user avatar
  • 61
0 votes
1 answer
202 views

I'm getting this Error: cannot estimate gas; transaction may fail or may require manual gas limit

MY CODE: const ethers = require("ethers"); const fs = require("fs-extra"); async function main() { // HTTP://172.17.32.1:7545 const provider = new ethers.providers....
Edward Kenway's user avatar
1 vote
1 answer
392 views

How to customize forge formatter in vscode

I'm using Foundry toolchain and vscode for my smart contracts development. As suggested by the Foundry documentation I applied the vscode integration tweaks and I'm using forge formatter to format my ...
forhas's user avatar
  • 785