Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [npm]

The tag has no usage guidance.

1
vote
1answer
10 views

How to resolve 'ethereumjs-testrpc@beta' error while using 'npm –g install ethereumjs-testrpc@beta' in Nodejs command prompt

While setting up my Solidity Environment Using NodeJS, Node Package Manager (NPM) and Truffle which was successfully installed. But at the point of running "npm –g install ethereumjs-testrpc@beta" I ...
0
votes
2answers
50 views

How to install web3 latest version manually in windows10?

I used npm install web3 which would install (as of now) v1.0.0-beta.41 But it gave me the following error: E:\sheep\node_modules\sha3>if not defined npm_config_node_gyp (node "C:\Program Files\...
0
votes
0answers
29 views

Truffle-contract cannot find module 'debug'

I'm trying to connect my smart contracts to a frontend app using web3 and the truffle-contract node package. In my client-side javascript file, I am requiring the package as follows: import contract ...
0
votes
0answers
48 views

Error in compiling the contract [duplicate]

I am getting this error while compiling the contract using solc: assert.js:350 throw err; ^enter code here AssertionError [ERR_ASSERTION]: Invalid callback specified This is my deploy.js file.......
2
votes
0answers
37 views

Installing Truffle without npm

I'm a student trying to install a truffle test RPC client (just for simple contract deployment in small scale). I am using a remote Ubuntu machine in my university, and i don't root privileges. ...
1
vote
1answer
112 views

Error while installing web3

I'm getting these errors while executing npm install web3 How could i fix this?
2
votes
1answer
261 views

TypeError: web3_1.default is not a constructor

I'm trying to convert a DApp that uses web3.js from JavaScript to TypeScript, but I have encountered a bunch of runtime errors. I'm using Visual Studio Code IDE, and I'm compiling to ES6. I've reduced ...