Questions tagged [les]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
11
votes
2answers
467 views

Does a light client require a chain of trust towards full nodes?

A full client does not need to trust any individual node on the Ethereum network, as the full client can see the activity from all nodes and discard any inconsistencies caused by ill intentioned nodes ...
4
votes
1answer
310 views

Get all transactions by recipient's address on a light client

I would like to continuously get the transactions sended to a specific address while using a light client. I underscore that I am talking about regular transactions, not the contract invocations. As ...
4
votes
0answers
326 views

Geth LES Client. Only synchronize the last 50 headers?

Using a LES client, is it possible to only synchronize only some of the last headers on first run ? I am not interested in the chain history. I understand the security implications of not validating ...
2
votes
1answer
62 views

What are the design targets which the light client is being developed against?

For example: persistent storage? volatile storage? connectivity? The closest I could get to a definition for the above is the following: "1KB of data per 2 minutes". However the following remains ...
1
vote
0answers
52 views

How to prioritize a light client to make sure it's never kicked out?

Running a geth full node on a dedicated server: geth --maxpeers 5000 --light.maxpeers 2000 --light.serve 500 --syncmode full I want to make sure it'll always accept my light client(s) even if its LES ...
1
vote
1answer
90 views

Usage of light node through the HTTP API

Am I correctly understanding that all I have to do to use a ethereum light node (started with a syncmode=light) is to call regular ethereum api as described in https://github.com/ethereum/wiki/wiki/...
1
vote
0answers
46 views

Supporting LES GetProofs Requests

When connecting a LES client to an Ethereum node and sending a GetProofsV2 request, I'm unable to get anything other then an empty ([]) response for the set of nodes. I suspect I've configured my ...