Questions tagged [installation]

Issues or questions pertaining to the installation or building process of Ethereum clients or Ethereum related software. ie: Installing Mist, building solc, etc. Typically these questions are also tagged with the operating system used (ie: windows, mac-osx).

Filter by
Sorted by
Tagged with
1
vote
1answer
634 views

How to rebuild solc on Mac OSX?

I need to rebuild solc on OSX. I followed http://solidity.readthedocs.org/en/latest/installing-solidity.html but old version still in place with solc --version. Is there a process to remove existing ...
1
vote
1answer
15 views

truffle command line version older than it is in package.json

After installing Truffle with yarn add truffle, the following line shows up in package.json: "truffle": "^5.1.52" In the root directory of the project, the truffle version ...
1
vote
1answer
25 views

Options to install Ethereum nodes in a corporate environment

The main issue to install an Ethereum node in a corporate environment is the possibility to receive connection from unknown nodes. The security department is always concerned in open new doors to ...
1
vote
3answers
3k views

geth console returns command not found on Mac

I am just getting started on ethereum programming on a Mac (OS Siera 10.12.6) and am trying to set up my environment. I am following the Ethereum.org installation instructions. I completed these ...
1
vote
1answer
641 views

Unable to install geth 1.5.9 ubuntu

I want to install geth 1.5.9 but I find only geth 1.6.0! How can I install geth with this specific version?
1
vote
1answer
385 views

Installing and running a node on ethereum

In order to install Geth, in terminal it did not work : bash <(curl https://install-geth.ethereum.org) and in browser also that URL did not work. Why it showing error like this? Link for ...
1
vote
1answer
509 views

Install and use Parity in Tails

I'm trying to install Parity. What i did is run: sudo dpkg -i Ethereum.deb And it suppose to be installed, but when I run: sudo parity It says: unable to execute /usr/bin/parity No such file ...
1
vote
1answer
102 views

Unable to install web3 on windows 10

This is the error I get when I try to install web3 on my machine. After installing git I have another issue: C:\Windows\system32> npm install web3 npm ERR! code ENOENT npm ERR! syscall spawn git ...
1
vote
0answers
461 views

Error while installing truffle-hdwallet-provider

I am on windows OS and my current python version is 3.6 and node version is v10.12.0 I am trying to install truffle-hdwallet-provider by running following command: npm install --save truffle-...
1
vote
1answer
5k views

How to fix “unexpected directory layout” error when Installing go-ethereum?

All, I hope this question belongs here. I am following a Blockgeeks tutorial, trying to set up my environment for Ethereum blockchain development. I have basically gotten to the final step, ...
1
vote
1answer
353 views

Installing web3

I was struggling with this problem for couple days, who know how to fix that ? Win7 C:\Users\Administrator>npm install web3 npm WARN deprecated fs-promise@2.0.3: Use mz or fs-extra^3.0 with ...
1
vote
1answer
81 views

Truffle console no compile or init options

While using truffle.cmd console I tried to use the compile option, or even init. These options are not available, so I cannot compile using console. truffle(development)> .help .break Sometimes ...
1
vote
0answers
162 views

Mist main wallet address changed after instalation

During the instalation of mist on a mac I get to the following screen: I then have to wait for synching to complete. During this time I can deposit ether into my wallet using Bitcoin or just use the ...
1
vote
0answers
519 views

Installing/Running Ethereum on Windows 10 (Bash)

I am having this problem when starting geth in the bash terminal from windows 10. I have copied the entire startup initialization hoping it would help. I0313 23:22:43.037940 node/config.go:445] ...
1
vote
0answers
524 views

testrpc install in windows

I'm getting this error while installing testrpc: C:\Users\user\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\src\win_delay_load_hook.c(34): error C2373: '__pfnDliNotifyHook2': ...
1
vote
2answers
3k views

Scrypt npm install fails with error C compiler cannot create executable

Can you please help me with this error? dhcp-rhodes-571:harberger-token kishorpatil$ sudo npm install scrypt > scrypt@6.0.3 preinstall /Users/kishorpatil/blockchain/radical-markets/harberger-...
0
votes
1answer
144 views

web3.js installation problem

I've ran into a problem trying to install web3. I went through here and stackover flow to try and solve the issue but had no success. I had to install python2.7 but still getting this error. Any ...
0
votes
1answer
498 views

How to install a Ethereum Classic Geth Client?

I was trying to install Go-Ethereum Classic in Ubuntu(VM) using the following guide https://github.com/ethereumproject/go-ethereum I followed the steps as per the guide and all went fine till $ ...
0
votes
2answers
944 views

web3.js library not loading properly

I am trying to load web3 library after installing it via command prompt. However, looks like it is not loading properly as it is not showing all the details for Ethereum ecosystem (ex. unitmap of ...
0
votes
1answer
200 views

Do I need a Linux VPS to start interacting with smart contracts?

I have only none to basic information about hosting with a VPS. I would like to deploy a smart contract and build a website to interact with the contract. Normally I use shared hosting which is very ...
0
votes
0answers
91 views

Drizzle Installation: pauses at fetchMetadata: sill resolveWithNewModule http-https@1.0

I am following this tutorial https://www.trufflesuite.com/tutorials/getting-started-with-drizzle-and-react. Everything is working smoothly until I have to npm install drizzle. I then run into the ...
0
votes
1answer
113 views

Problem installing Swarm

I have a problem installing Swarm. when i enter sudo apt-get install ethereum-swarm i get a problem saying : dpkg: error processing archive /var/cache/apt/archives/ethereum-swarm_0.3.1+build14601+...
0
votes
0answers
140 views

“'parity' is not recognized as an internal or external command, operable program or batch file.”

I downloaded Parity installer from here : https://www.parity.io/ and then installed it on computer with OS Windows 8.1. Then even I restatred computer. However, when I use following command: parity ...
0
votes
0answers
488 views

Ubuntu 16.04: Truffle: command not found

I installed the truffle on my Ubuntu machine and it installed successfully but when i am trying to execute truffle commands it is saying; truffle: command not found I tried the solution mentioned in ...
0
votes
2answers
190 views

Installation of pyethapp fails on Raspberry Pi

I'm trying to install pyethapp on Raspberry PI B+ sudo pip install pyethapp getting error Complete output from command python setup.py egg_info: Couldn't find index page for 'pytest-runner' (maybe ...
0
votes
1answer
98 views

Switched from the Ethereum Wallet's test network to main network and need to remove the previous data

I was on the Ethereum Wallet's test network and finally worked out all the code, but now that I have switched over to the main network I've had to download a lot of the preexisting blocks and has my ...
0
votes
1answer
726 views

geth installation with homebrew stuck at Checking out tag v1.7.0

i am a complete newbie in the ethereum space and is trying to install geth on my mac using homebrew after the step : ==> Cloning https://github.com/ethereum/go-ethereum.git the process has stuck at ...

1
2