0

I'm running Ganache with a fork of mainnet with Remix - when I try and debug a transaction by clicking on the 'debug' button after sending a transaction, it sends me to the debug screen. When I then skip around using the slider, the debug screen completely goes blank.

Am I doing something wrong here? This always happens so I can't actually debug properly.

enter image description here

EDIT: Chrome Dev tools shows the following errors when this happens:

enter image description here

0

I'm seeing this issue too.

It looked promising at first - I could see the local variables, state variables, stack and opcodes in the debug panel. But when I tried to move through the code (tried step into/over and also the slider) the debug panel just disappeared and I couldn't seem to recover it.

EDIT: Doing some further digging, my theory is that my local version of the Ganache UI doesn't support methods such as debug_storageRangeAt - but looking at the Ganache docs I see it is supported:

https://trufflesuite.github.io/ganache-core/#debug_storageRangeAt

I've updated my Ganache UI app to the latest v2.5.4 but it still doesn't resolve the bug 🤷🏻‍♂️

I can see there's an open issue with ganache-cli:

https://github.com/trufflesuite/ganache-cli/issues/248

So maybe debugging transactions on Remix via Ganache isn't possible yet?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.