0

Hi i am trying to setup work environment by connecting local files to remix ide

i keep getting this error when i run code

remixd -s "absolute url path" --remix-ide https://remix.ethereum.org

and the output [Error: EACCES: permission denied, open '/usr/local/lib/node_modules/@remix-project/remixd/origins.json'] { errno: -13, code: 'EACCES', syscall: 'open', path: '/usr/local/lib/node_modules/@remix-project/remixd/origins.json' } [WARN] You may now only use IDE at https://remix.ethereum.org to connect to that instance [WARN] Any application that runs on your computer can potentially read from and write to all files in the directory. [WARN] Symbolic links are not forwarded to Remix IDE

2
  • Hi there. Have you tried running the command with sudo? May 22 '21 at 7:22
  • @RichardHorrocks yes i have still no dice, it looks like a permission issue though May 23 '21 at 21:12
0

Check your remix url : https://remix.ethereum.org instead of http://remix.ethereum.org

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.