0

I cannot transfer from my Account1 to Account2 in MetaMask using Send

either choosing "Transfer between my acccounts" or pasting address for Account2 (that is valid and starts with "0x", e.g. just copied from metamask)

(Transfering to other people account had the same bug)

gives me the same error (see below) "HBT Test" is not address, not even network type, this is actually name of main currency (not ERC20 token)

MetaMask encountered an error
Try again by reloading the page, or contact support here.
Error Details
Message: This method only supports 0x-prefixed hex strings but input was: HBT Test

Code: Error

Stack:

Error: This method only supports 0x-prefixed hex strings but input was: HBT Test
  at Object.r.assertIsHexString (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:210305)
  at Object.r.toChecksumAddress (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:72:201511)
  at _ (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:653574)
  at h.render (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:478592)
  at Ya (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:70734)
  at Ka (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:70529)
  at jl (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:105704)
  at bu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:90053)
  at pu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:89978)
  at iu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:87326)
  at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45768
  at r.unstable_runWithPriority (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:172:3472)
  at Vo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45477)
  at Yo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45713)
  at Ko (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45648)
  at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:114643
  at ue (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:114649)
  at fe (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:5411)
  at Rr (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:29682)
  at Cr (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:30610)
  at Tr (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:29898)
  at r.unstable_runWithPriority (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:172:3472)
  at Vo (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:45477)
  at le (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:114479)
  at Er (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:29321)
  at HTMLDocument.c (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/initSentry.js:1:10460)

error

3
  • 1
    Hi there. It might be best to report this to Metamask directly: github.com/MetaMask/metamask-extension/issues Looking through the recently opened issues might also be a good start. May 11, 2021 at 7:30
  • 1
    HBT test might be your token name and the chain it's on might not be tracked. We could hop on chat if you need help. May 11, 2021 at 7:33
  • well, removing main currency name (that is marked as optional) helped May 11, 2021 at 7:42

1 Answer 1

0

Well, the issue was solved by identifying that it was name of main balance currency on the HECO testnetwork,

then removing the name of currency helped to overcome this bug.

MetaMask Settings -> Networks -> [used test network]

I must says it pain to edit the Currency Symbol field as it was making MetaMask very slow, unresponsive and input or cursor were not shown,

network currency symbol

Now MetaMask is showing main balance as in ETH (that is not correct), but it does not fail to transfer between accounts.

1
  • The currencyname has some effect on the transactions? I would have expected that was only a label on the client
    – Stormsson
    Oct 19, 2021 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.