0

I have configured 3 ethereum nodes 2 in GCP VMS 1 in RPI All are Ubuntu based

Miner1: geth --identity "miner1" --networkid 42 --datadir "~/RPI/miner1" --nodiscover --mine --rpc --rpcaddr 0.0.0.0 --rpcport "8042" --port "30303" --allow-insecure-unlock --unlock 0 --password "password.sec" --ipcpath "~/.ethereum/geth.ipc" --rpcapi "db,eth,net,web3,personal,miner,admin,txpool,debug"

Miner2 geth --identity "miner2" --networkid 42 --datadir "~/RPI/miner2" --nodiscover --mine --rpc --rpcaddr 0.0.0.0 --rpcport "8043" --port "30304" --allow-insecure-unlock --unlock 0 --password "password.sec" --rpcapi "db,eth,net,web3,personal,miner,admin,txpool,debug"

RPI geth --identity "node2" --networkid 42 --datadir "node" --nodiscover --mine --rpc --rpcaddr 0.0.0.0 --rpcport "8042" --port "30303" --unlock 0 --password "password.sec" --ipcpath "/home/ubuntu/.ethereum/geth.ipc" --rpcapi "db,eth,net,web3,personal,miner,admin,txpool,debug"

but admin.peers is successful between Miner1 and Miner2 But RPI is not peered.

GCP firewall configuration:

GCP Firewall settings In GCP, top navigation->VPC Network->Firewall Name=ethereum Ingress Tag name=miner IP range=0.0.0.0/0 TCP = 30303,30304 UDP = 30303,30304 Create In VMs, Edit VM Network tag name = miner Save VMs Re-start VMs

In GCP, top navigation->VPC Network->Firewall Name=allow-rpc Ingress Tag name=rpc IP range=0.0.0.0/0 TCP = 8042,8043 Create In VMs, Edit VM Network tag name = rpc Save VMs Re-start VMs

Questions:

  1. Why RPI is not peered with Miner1 and Miner2?
  2. Any GCP firewall setting is missing?
  3. Any UBUNTU ufw setting is required?

Update: GCP VMs are getting peered with other 2 miners running on another Ubuntu PC. So the problem is from RPI. Some configuration is not correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.